RoboterCC - Robotic Code Compiler
Forum Robot Kits Andere Roboter / Robotik allgemein XBEE Modul - welches sollte man nehmen?

Welcome

Nachrichten

Sie sind nicht eingeloggt.

Werbung

Letzte Themen

  • Keine Beiträge vorhanden

Site-Statistic

  • 6735 private projects
  • 374 public projects
  • 12084878 lines compiled
  • 51742 builds
NIBO @ facebook YouTube Twitter
Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: XBEE Modul - welches sollte man nehmen?

XBEE Modul - welches sollte man nehmen? 7 Jahre 5 Monate her #2916

  • BirgerT
  • BirgerTs Avatar
  • OFFLINE
  • Gold Boarder
  • Beiträge: 325
Die Abbildung auf der UCOM XBEE Doku zeigt augenscheinlich ein Series 1 Module mit Chip-Antenne (?!).

Aber welches sollte man für den NIBO2 nehmen:
804.15, DigiMesh oder ZigBee Protokoll?
2,4 GHz oder 868MHz?
Series 1 oder Series 2?
Normal oder PRO?
Eins für 25 oder eins für 80 EUR?

Habe hier im Forum und im Wiki nix gefunden.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

XBEE Modul - welches sollte man nehmen? 7 Jahre 5 Monate her #2919

  • workwind
  • workwinds Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 572
Ich verwende die 802.15.4 Module in Normal und Pro Version, mit Draht und mit Chip Antenne.

Die Pro Version ist nicht notwendig - Du darfst die höhere Sendeleistung in Europa eh nicht ganz ausfahren...

Bei Draht- oder Chipantenne lass ich mich ganz von der optischen Erscheinung lenken: Mit Draht sieht man die Antenne besser! ;)

-workwind-
Der Administrator hat öffentliche Schreibrechte deaktiviert.

XBEE Modul - welches sollte man nehmen? 7 Jahre 5 Monate her #2935

  • BirgerT
  • BirgerTs Avatar
  • OFFLINE
  • Gold Boarder
  • Beiträge: 325
Habe hier im Forum und im Wiki nix gefunden.

..jetzt schon. wenn man in der Suchfunktion "vor 1 Jahr" und "und älter" auswählt.. findet sich auch was zu XBEE

Allerdings ist hier nirgends beschrieben, wie sich die Teile in Betrieb nehmen lassen, deswegen für alle die es noch versuchen wollen nur ein paar Stichpunkte:

Ich verwende jetzt diese Module www.reichelt.de/ZIGBEE-XBEE-ZBCA/3/index.html?&ACTION=3&LA=446&ARTICLE=108355&artnr=ZIGBEE+XBEE+ZBCA&SEARCH=xbee weil die recht günstig sind und auch ZigBee Mesh unterstützen.

Im Netzwerk wird genau ein Modul als 'Coordinator' benötigt, und dann ein 'Router' oder ein 'End-Device'. Welche Funktion das Modul hat, wird über die Firmware bestimmt, die mit dem Programm X-CTU (kostenloser Download von der Digi Site) erst mal geflasht werden werden muss.

Also XBEE Modul in UCOM XBEE stopfen, UCOM XBEE an den PC stöpseln und etwas warten, bis die Geräte Software (LUFA) installiert wurde, und im Gerätemanager schauen, welcher COM-Port dafür vergeben wurde (eventuell ändern, Bray-Term kann nur bis COM7).
X-CTU starten (dauert) und auf der linken Fensterhälfte Modul einfügen, COM Port vom UCOM XBEE auswählen und Button 'Finish' anklixen.
Das Modul wird links angezeigt, anklicken und das Modul wird ausgelesen und die Parameter auf der rechten Fensterhälfte angezeigt.
Über der rechten Fensterhälfte sind jetzt verschiedene Symbole für Lesen, Schreiben, Werkseinstellung, Firmware und Profil.

Zuerst der Router für den NXB2 am NIBO2 (Function Set sollte 'ZigBee Router AT' zeigen, ansonsten Funktion flashen s.u.):
Nachdem die Parameter eingelesen wurden, müssen die folgenden geändert werden (für eine Beschreibung im X-CTU auf das (i) vor der Zeile klicken):

ID = Netzwerkadresse, die dann bei allen Modulen gleich sein muss, zum Bsp. Geburtsdatum oder Postleitzahl oder.. Zahl notieren
DH = Ziel Moduladresse High (sowas wie die MAC einer Netzwerkkarte) ist bei DIGI-Modulen immer 13A200 -> eingeben
DL = Ziel Moduladresse Low, hier ist die Seriennummer des anderen Moduls einzutragen, die steht auf der Modul Unterseite unter dem 00132A00, bei mir ist's beim 1. Modul 40B552B9.
NI = Modulname im Klartext, weil ich den ROUTER am ersten NIBO2 hängen habe, ist's bei mir NIBO2#747
Weiter unten auf der Seite kann man noch Baudrate und anderen Kram einstellen, aber das lassen wir erstmal..

Mit dem Stift über der Parameterseite die Änderungen im XBEE Modul speichern.
UCOM XBEE vom PC abstöpseln, XBEE Modul aus dem UCOM XBEE in den NXB2 transplantieren.

Zweites XBEE Modul in UCOM XBEE stecken (Tipp/Eselsbrücke: die abgeschrägte Seite muss immer neben den beiden kleinen LEDS sein), UCOM XBEE am PC anstöpseln. Im X-CTU wieder Modul hinzufügen und das vorhandene Modul ruhig entfernen.

Das soll jetzt der COORDINATOR werden, der dann im UCOM XBEE stecken bleibt.

Symbol Firmware auswählen, Fenster mit OK schliessen und den ZIGBEE COORDINATOR AT mit der 'newest' Version auswählen und schreiben.
Bitte das mit "AT" auswählen, dann lassen sich die Module später auch über AT-Befehle im Terminal konfigurieren.

Nachdem die Parameter wieder neu eingelesen wurden, müssen auch hier die folgenden geändert werden:

ID = Netzwerkadresse, die gleiche Zahl, wie s.o. notiert
DH = Ziel Moduladresse High 13A200 -> eingeben
DL = Ziel Moduladresse Low, hier jetzt ist die Seriennummer des anderen Moduls vom NXB2 eingeben
NI = Modulname im Klartext, weil ich den COORDINATOR am PC hängen habe, ist's bei mir TERMINAL
und mit dem Stift über der Parameterseite die Änderungen im XBEE Modul speichern.

Wenn beide Module 'unter Spannung' stehen, sollten die grünen LEDs langsam blinken und eine Verbindung anzeigen, wurde ein Telegramm übertragen leuchten die gelben LEDs für ca 10 Sek. auf.

Zur Zeit ist das Projekt hier noch am besten geeignet
www.roboter.cc/index.php?option=com_nicaiwci&view=project&Itemid=41&projectid=2778

weil die Erfahrung steht hier
www.roboter.cc/index.php?option=com_kunena&view=topic&catid=13&id=2002&limitstart=30&Itemid=20
Der Administrator hat öffentliche Schreibrechte deaktiviert.

XBEE Modul - welches sollte man nehmen? 5 Jahre 10 Monate her #3543

  • BirgerT
  • BirgerTs Avatar
  • OFFLINE
  • Gold Boarder
  • Beiträge: 325
Habe derzeit die Kombination
- Nibo Burger mit Arduino Wireless SD Shield mit XBEE Modul
- und UCOM-XBEE (mit XBEE-Modul) am Start..


Auf dem UCOM-XBEE gibt es drei LEDs
- grün = Blinkt wenn Funkverbindung besteht
- gelb = zeigt Datenverkehr an
- DUO = ?

Was soll die DUO-LED anzeigen?
Beim Anstöpseln an den Rechner ist diese kurz grün und dann leuchtet sie dauerhaft rot :kopfkratz:
Leuchtet die auch mal "orange"?
Der Administrator hat öffentliche Schreibrechte deaktiviert.
  • Seite:
  • 1
Ladezeit der Seite: 0.042 Sekunden

Werbung